Como explican en symfony.org symfony-project.org, las versiones 1.3 y 1.4 tienen las mismas características. La unica diferencia entre ambas es la compatibilidad hacia versiones anteriores que tienen:
  • Symfony 1.3 se usara en caso de que tengas que actualizar un proyecto desarrollado con una versión vieja de symfony (1.0, 1.1 o 1.2). Tiene una capa de compatibilidad para versiones anteriores que hace que todas las características que se han quedado obsoletas en la versión 1.3 aun estén disponibles.
  • Symfony 1.4 es la versión recomendada en caso de tener que desarrollar un nuevo proyecto a día de hoy. Esta versión es mas rápida que la 1.3, además tiene soporte extendido hasta Noviembre del 2012.